Vmware 1.06 & kernel 2.6.26 ..

Encore une belle galère..

Les patch any-to-any semblaient marcher au niveau de la compil (tout du moins les 117*, mais au moment de lancer une machine virtuell, j'avais droit à un beau message d'erreur avec Version mismatch with vmmon module: expecting 138.0, got 168.0 .

finalement, j'ai trouvé la solution ici.

Télécharger les patchs de paldo (sur cette page) puis suivre le même process que pour la version precedente:

  • Installer vmware-server (sans patch, et sans lancer la configuration)
  • créer un repertoire temporaire
    $ mkdir ~/tmpatch
    y placer les fichier vmmon.tar et vmnet.tar
    $ cp /usr/lib/vmware/modules/source/vm*.tar ~/tmpatch/
    les decompresser
    $ cd ~/tmpatch; tar xvf vmmon.tar; tar xvf vmnet.tar
  • telecharger les 2 patchs de paldo
    $ wget http://www.paldo.org/paldo/sources/VMware-server/VMware-server-vmmon-1.0.6-91891-2.6.26-1.patch.bz2;  wget http://www.paldo.org/paldo/sources/VMware-server/VMware-server-vmnet-1.0.6-91891-2.6.26-1.patch.bz2 )
  • les decompresser
    $ bunzip *.bz2
  • patcher
    • vmmon
      $ cd vmmon-only; patch -p1 < ../VMware-server-vmmon-1.0.6-91891-2.6.26-1.patch
    • puis vmnet
      $ cd ../vmnet-only; patch -p1 < ../VMware-server/VMware-server-vmnet-1.0.6-91891-2.6.26-1.patch
  • [optionnel] archiver les fichiers d'origine 'au cas ou'
    $ mv vmmon.tar vmmon.tar.orig; mv vmnet.tar vmnet.tar.orig
  • Recompresser les modules patchés
    $ tar vmmon.tar vmmon-only; tar vmnet.tar vmnet-only
  • Les recopier à la pace des fichiers d'origine
    # cp *.tar  /usr/lib/vmware/modules/source/ [necessite d'etre en root, ou sudo, ou su -c ]
  • lancer la configuration .. (en root ou sudo, ou su -c)
    # vmware-config.pl
  • Enjoy ....

Merci à Paldo pour les patch et à Lenrek de l'avoir pointé :)

 

A j'oubliais.. config de mon poste, ca peut tjs aider à comprendre pourquoi ce qui marche sur une machine ne marche pas ailleurs..

$ cat /etc/frugalware-release
Frugalware 0.9rc1.97.g137c167 (Solaria)

$ uname -r
2.6.26-fw1

Bonjour, j'ai été obligé

Bonjour,

j'ai été obligé de modifier un peu patch.

Chez moi ça donne: 

cd vmmon-only;

patch -p1 < ../VMware-server-vmmon-1.0.6-91891-2.6.26-1.patch

Cdt.

Merci

En effet, oubli de ma part :-/ Je l'ai corrigé, merci encore.

 Et tant qu'à faire, j'en ai profité pour arranger un peu la mise en page, plus lisible comme ça je penses

Powered by Drupal, an open source content management system
titrepage = document.title */ ?>